lua

lua

CentOS编译安装Vim让其支持lua

CentOSliuliangsong 发表了文章 • 0 个评论 • 299 次浏览 • 2016-12-14 10:23 • 来自相关话题

  vim有很多插件依赖于lua功能,但是默认系统自带的vim和使用yum安装的vim都不带lua功能,所以我们需要自己编译安装。要查看vim支不支持lua,打开vim,在命令模式输入“:version”即可以看到vim的一些版本和编译信息,其中"+lua"表示支持lua,"-lua"表示不支持lua。


 
 一、卸载自带的vim:  为了避免冲突,首先我们要卸载掉系统自带的vim,使用"yum -y remove vim-*"命令卸载:yum -y remove vim-* 二、安装vim相关软件:1、安装软件编译工具包集:yum -y groupinstall 'Development tools' 2、安装编译vim必须的依赖包:yum -y install ncurses ncurses-devel
yum -y install lua lua-devel 三、编译安装vim:  既然是编译安装,当然是安装最新版的vim,所以我们这次编译安装的是vim8.0。最新版本的vim可以从vim的官网上查找下载地址:http://www.vim.org/
 1、下载并解压vim安装包:cd /usr/local/src
wget ftp://ftp.vim.org/pub/vim/unix/vim-8.0.tar.bz2
tar -xjf vim-8.0.tar.bz2
cd vim80/ 2、编译安装支持lua的vim:./configure --prefix=/usr --with-features=huge --enable-rubyinterp --enable-pythoninterp --enable-luainterp --with-lua-prefix=/usr
make && make install 3、卸载编译安装的vim:  这一步现在不要执行,只是讲编译安装的卸载方法,用来将来的卸载;要卸载编译安装的vim,必须将vim的编译目录“/usr/local/src/vim80/”保留,在编译目录执行卸载操作:[root@aiezu vim80]# cd /usr/local/src/vim80/
[root@aiezu vim80]# make uninstall
[root@aiezu vim80]# make clean 四、安装完成:  安装完成后,使用"vim --version"命令可以看出,已经支持lua啦,效果如下图,开始安装你想要的插件吧。




  查看全部
  vim有很多插件依赖于lua功能,但是默认系统自带的vim和使用yum安装的vim都不带lua功能,所以我们需要自己编译安装。要查看vim支不支持lua,打开vim,在命令模式输入“:version”即可以看到vim的一些版本和编译信息,其中"+lua"表示支持lua,"-lua"表示不支持lua。
linux_vim_makeinstall_enable_lua.png
 
 

一、卸载自带的vim:

  为了避免冲突,首先我们要卸载掉系统自带的vim,使用"yum -y remove vim-*"命令卸载:
yum -y remove vim-*
 

二、安装vim相关软件:

1、安装软件编译工具包集:

yum -y groupinstall 'Development tools'
 

2、安装编译vim必须的依赖包:

yum -y install ncurses ncurses-devel
yum -y install lua lua-devel
 

三、编译安装vim:

  既然是编译安装,当然是安装最新版的vim,所以我们这次编译安装的是vim8.0。最新版本的vim可以从vim的官网上查找下载地址:http://www.vim.org/
 

1、下载并解压vim安装包:

cd /usr/local/src
wget ftp://ftp.vim.org/pub/vim/unix/vim-8.0.tar.bz2
tar -xjf vim-8.0.tar.bz2
cd vim80/
 

2、编译安装支持lua的vim:

./configure --prefix=/usr --with-features=huge --enable-rubyinterp --enable-pythoninterp --enable-luainterp --with-lua-prefix=/usr
make && make install
 

3、卸载编译安装的vim:

  这一步现在不要执行,只是讲编译安装的卸载方法,用来将来的卸载;要卸载编译安装的vim,必须将vim的编译目录“/usr/local/src/vim80/”保留,在编译目录执行卸载操作:
[root@aiezu vim80]# cd /usr/local/src/vim80/
[root@aiezu vim80]# make uninstall
[root@aiezu vim80]# make clean
 

四、安装完成:

  安装完成后,使用"vim --version"命令可以看出,已经支持lua啦,效果如下图,开始安装你想要的插件吧。
linux_vim_makeinstall_enable_lua_02.png


 

CentOS编译安装Vim让其支持lua

CentOSliuliangsong 发表了文章 • 0 个评论 • 299 次浏览 • 2016-12-14 10:23 • 来自相关话题

  vim有很多插件依赖于lua功能,但是默认系统自带的vim和使用yum安装的vim都不带lua功能,所以我们需要自己编译安装。要查看vim支不支持lua,打开vim,在命令模式输入“:version”即可以看到vim的一些版本和编译信息,其中"+lua"表示支持lua,"-lua"表示不支持lua。


 
 一、卸载自带的vim:  为了避免冲突,首先我们要卸载掉系统自带的vim,使用"yum -y remove vim-*"命令卸载:yum -y remove vim-* 二、安装vim相关软件:1、安装软件编译工具包集:yum -y groupinstall 'Development tools' 2、安装编译vim必须的依赖包:yum -y install ncurses ncurses-devel
yum -y install lua lua-devel 三、编译安装vim:  既然是编译安装,当然是安装最新版的vim,所以我们这次编译安装的是vim8.0。最新版本的vim可以从vim的官网上查找下载地址:http://www.vim.org/
 1、下载并解压vim安装包:cd /usr/local/src
wget ftp://ftp.vim.org/pub/vim/unix/vim-8.0.tar.bz2
tar -xjf vim-8.0.tar.bz2
cd vim80/ 2、编译安装支持lua的vim:./configure --prefix=/usr --with-features=huge --enable-rubyinterp --enable-pythoninterp --enable-luainterp --with-lua-prefix=/usr
make && make install 3、卸载编译安装的vim:  这一步现在不要执行,只是讲编译安装的卸载方法,用来将来的卸载;要卸载编译安装的vim,必须将vim的编译目录“/usr/local/src/vim80/”保留,在编译目录执行卸载操作:[root@aiezu vim80]# cd /usr/local/src/vim80/
[root@aiezu vim80]# make uninstall
[root@aiezu vim80]# make clean 四、安装完成:  安装完成后,使用"vim --version"命令可以看出,已经支持lua啦,效果如下图,开始安装你想要的插件吧。




  查看全部
  vim有很多插件依赖于lua功能,但是默认系统自带的vim和使用yum安装的vim都不带lua功能,所以我们需要自己编译安装。要查看vim支不支持lua,打开vim,在命令模式输入“:version”即可以看到vim的一些版本和编译信息,其中"+lua"表示支持lua,"-lua"表示不支持lua。
linux_vim_makeinstall_enable_lua.png
 
 

一、卸载自带的vim:

  为了避免冲突,首先我们要卸载掉系统自带的vim,使用"yum -y remove vim-*"命令卸载:
yum -y remove vim-*
 

二、安装vim相关软件:

1、安装软件编译工具包集:

yum -y groupinstall 'Development tools'
 

2、安装编译vim必须的依赖包:

yum -y install ncurses ncurses-devel
yum -y install lua lua-devel
 

三、编译安装vim:

  既然是编译安装,当然是安装最新版的vim,所以我们这次编译安装的是vim8.0。最新版本的vim可以从vim的官网上查找下载地址:http://www.vim.org/
 

1、下载并解压vim安装包:

cd /usr/local/src
wget ftp://ftp.vim.org/pub/vim/unix/vim-8.0.tar.bz2
tar -xjf vim-8.0.tar.bz2
cd vim80/
 

2、编译安装支持lua的vim:

./configure --prefix=/usr --with-features=huge --enable-rubyinterp --enable-pythoninterp --enable-luainterp --with-lua-prefix=/usr
make && make install
 

3、卸载编译安装的vim:

  这一步现在不要执行,只是讲编译安装的卸载方法,用来将来的卸载;要卸载编译安装的vim,必须将vim的编译目录“/usr/local/src/vim80/”保留,在编译目录执行卸载操作:
[root@aiezu vim80]# cd /usr/local/src/vim80/
[root@aiezu vim80]# make uninstall
[root@aiezu vim80]# make clean
 

四、安装完成:

  安装完成后,使用"vim --version"命令可以看出,已经支持lua啦,效果如下图,开始安装你想要的插件吧。
linux_vim_makeinstall_enable_lua_02.png


 

CentOS编译安装Vim让其支持lua

CentOSliuliangsong 发表了文章 • 0 个评论 • 299 次浏览 • 2016-12-14 10:23 • 来自相关话题

  vim有很多插件依赖于lua功能,但是默认系统自带的vim和使用yum安装的vim都不带lua功能,所以我们需要自己编译安装。要查看vim支不支持lua,打开vim,在命令模式输入“:version”即可以看到vim的一些版本和编译信息,其中"+lua"表示支持lua,"-lua"表示不支持lua。


 
 一、卸载自带的vim:  为了避免冲突,首先我们要卸载掉系统自带的vim,使用"yum -y remove vim-*"命令卸载:yum -y remove vim-* 二、安装vim相关软件:1、安装软件编译工具包集:yum -y groupinstall 'Development tools' 2、安装编译vim必须的依赖包:yum -y install ncurses ncurses-devel
yum -y install lua lua-devel 三、编译安装vim:  既然是编译安装,当然是安装最新版的vim,所以我们这次编译安装的是vim8.0。最新版本的vim可以从vim的官网上查找下载地址:http://www.vim.org/
 1、下载并解压vim安装包:cd /usr/local/src
wget ftp://ftp.vim.org/pub/vim/unix/vim-8.0.tar.bz2
tar -xjf vim-8.0.tar.bz2
cd vim80/ 2、编译安装支持lua的vim:./configure --prefix=/usr --with-features=huge --enable-rubyinterp --enable-pythoninterp --enable-luainterp --with-lua-prefix=/usr
make && make install 3、卸载编译安装的vim:  这一步现在不要执行,只是讲编译安装的卸载方法,用来将来的卸载;要卸载编译安装的vim,必须将vim的编译目录“/usr/local/src/vim80/”保留,在编译目录执行卸载操作:[root@aiezu vim80]# cd /usr/local/src/vim80/
[root@aiezu vim80]# make uninstall
[root@aiezu vim80]# make clean 四、安装完成:  安装完成后,使用"vim --version"命令可以看出,已经支持lua啦,效果如下图,开始安装你想要的插件吧。




  查看全部
  vim有很多插件依赖于lua功能,但是默认系统自带的vim和使用yum安装的vim都不带lua功能,所以我们需要自己编译安装。要查看vim支不支持lua,打开vim,在命令模式输入“:version”即可以看到vim的一些版本和编译信息,其中"+lua"表示支持lua,"-lua"表示不支持lua。
linux_vim_makeinstall_enable_lua.png
 
 

一、卸载自带的vim:

  为了避免冲突,首先我们要卸载掉系统自带的vim,使用"yum -y remove vim-*"命令卸载:
yum -y remove vim-*
 

二、安装vim相关软件:

1、安装软件编译工具包集:

yum -y groupinstall 'Development tools'
 

2、安装编译vim必须的依赖包:

yum -y install ncurses ncurses-devel
yum -y install lua lua-devel
 

三、编译安装vim:

  既然是编译安装,当然是安装最新版的vim,所以我们这次编译安装的是vim8.0。最新版本的vim可以从vim的官网上查找下载地址:http://www.vim.org/
 

1、下载并解压vim安装包:

cd /usr/local/src
wget ftp://ftp.vim.org/pub/vim/unix/vim-8.0.tar.bz2
tar -xjf vim-8.0.tar.bz2
cd vim80/
 

2、编译安装支持lua的vim:

./configure --prefix=/usr --with-features=huge --enable-rubyinterp --enable-pythoninterp --enable-luainterp --with-lua-prefix=/usr
make && make install
 

3、卸载编译安装的vim:

  这一步现在不要执行,只是讲编译安装的卸载方法,用来将来的卸载;要卸载编译安装的vim,必须将vim的编译目录“/usr/local/src/vim80/”保留,在编译目录执行卸载操作:
[root@aiezu vim80]# cd /usr/local/src/vim80/
[root@aiezu vim80]# make uninstall
[root@aiezu vim80]# make clean
 

四、安装完成:

  安装完成后,使用"vim --version"命令可以看出,已经支持lua啦,效果如下图,开始安装你想要的插件吧。
linux_vim_makeinstall_enable_lua_02.png